Vizzy!
Vizzy!

V.E.R.B.L.E.N.D.E.T.: Versatile Electronic Replicant Built for Logical Exploration, Nocturnal Destruction and Efficient Troubleshooting
 
 

prepare system:
SCons need to be installed http://www.scons.org.

now move/rename your yafray installation (e.g. 'mv /usr/bin/yafray /usr/bin/yafray.old' - and 'mv /usr/lib/yafray /usr/lib/yafray.old'), or
remove all previous installations of yafray!, on fedora : 'yum remove yafray' ... be sure to have no more yafray installations
check /usr/bin/yafray and /usr/lib/yafray


you may also remove builts from previous installations.... chekc your path settings.

be sure youre not root. you dont need to be root to compile your software. only instalation of yafray to e.g. /usr/local/ needs root privileges.

1.) Compile and Install Yafray from CVS: build yafray from cvs updated
2.) Compile and build Blender from CVS: build blender from cvs updated

NOTES:
do:

  • be sure you first remove or move/rename your yafray installation from /usr/bin and /usr/lib
  • first compile yafray, then compile blender. this is because blender searches for yafray installatoin and libs. both, yafray and blender must be compiled wit the same compiler , or you may get segfaults or exhausted memory errors and blender crashes.
  • if you got segfaults or blender hanging up during rendering.... check your yafray installation. ... did you start old blender? have you installed another yafray?

loop

 


...i'll make some better shellscript if i got more time :)

any questions or suggestion ? please contact me and let me know :)

special thx goes to: lynx3d, doopidup, charolastra for useful tips and testings

Links from this page:
| build yafray from cvs updated | build blender from cvs updated | Kontakt / Contact |

Vizzy!